Citrix

Error: "Your app is not available. Try again later"

  • CTX136377
  • Created onMar 26, 2014
  • Updated onMay 27, 2014
Article Topic Connectivity

Symptoms or Error

Applications fail to launch on XenApp 6.5 Farm using Citrix Receiver. The error message “Your app is not available. Try again later” is displayed on the Citrix Receiver.
User-added image

Solution

To resolve the issue, check the following for any failures:

  • proxies

  • network routing

  • firewalls

  • certificates

  • DNS configurations

Note: The XenApp policy for DNS Address resolution can be disabled to use IP address. If enabled, FQDN of server is sent to the ICA file.

Problem Cause

The error message occurs because of network issue between the Citrix Receiver client and XenApp servers. FQDNS of XenApp uses the address from the contents of the ICA file. It was identified later that the FQDN is a non-routable address. ICA launch files can be found at the following locations:

  • Web Interface
    C:\Users\$username$\AppData\Local\Temp

  • StoreFront
    C:\Users\$username$\AppData\Local\Citrix\SelfService\Temp

Automatic translation

Important: This article was translated by an automatic translation system (also referred to as Machine Translation, or MT) and has not been translated or reviewed by people. Citrix offers a machine translated version of this article to allow for greater access to the support content. However, automatic translation is not always perfect and may contain errors of vocabulary, syntax or grammar. Citrix is not responsible for inconsistencies, errors or damage incurred as a result of the use of MT articles from our customers.Thank you.
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