Citrix

Citrix Receiver Does Not Respond When Opening Applications to XenApp Servers

  • CTX132653
  • Created onMar 26, 2014
  • Updated onApr 07, 2014
Article Topic Connectivity

Symptoms or Error

When you open applications to XenApp servers, there is no response at the “Launching…” prompt, as shown in the following screen shot:

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Eventually, you might get any of the following errors:
“Attempting to reconnect…”

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Or

“Unable to launch your application…”

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Additional Symptoms

  • The output of a Netstat command on both client and server indicate that a valid connection is made on ICA ports 1494 or 2598, as shown in the following screenshot:
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  • Record a network packet trace on the client. The TCP stream indicates the following at the end of the conversation ( containing either “Vergence or “Sentillion” as the text):
VergenceVCCl.ICA......c5...`.......................................................................................................................................................................................
................................................VergenceVCCl.ICA......c5...`.......................................................................................................................................
................................................................................................VergenceVCCl.ICA......c5...`..............................
  • A CDF trace on the XenApp server might indicate the Vergence or Sentillion driver call:
INIT_RESPONSE: 2, class 3, bc 256, dll VergenceVCCl

Solution

To resolve the issue, complete the following procedure:

  1. Update the Sentillion/Vergence driver to the latest version.

  2. Change the properties of the module.ini file to read-only in the c:\Program Files\Citrix\ folder. 

This issue is strictly related to the integration of the Microsoft Sentillion or Vergence virtual channel driver into the Citrix ICA client by using the module.ini. If the problem persists, it is recommended to report the issue to Microsoft for further investigation.

Problem Cause

The cause of the issue is an incorrect module.ini file in the c:\Program Files\Citrix\ folder that is modified by the Sentillion/Vergence SSO product.

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Additional Resources

Microsoft Sentillion or Vergence uses these settings in the module.ini to load a virtual channel to facilitate SSO into a hosted published application on a XenApp server.

Applicable Products

Automatic translation

Important: This article was translated by an automatic translation system (also referred to as Machine Translation, or MT) and has not been translated or reviewed by people. Citrix offers a machine translated version of this article to allow for greater access to the support content. However, automatic translation is not always perfect and may contain errors of vocabulary, syntax or grammar. Citrix is not responsible for inconsistencies, errors or damage incurred as a result of the use of MT articles from our customers.Thank you.
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