Citrix

Receiver Application Synchronization Fails in a Roaming Profile Environment

  • CTX131325
  • Created onMar 26, 2014
  • Updated onApr 18, 2014
Article Topic Connectivity, Interoperability

Symptoms or Error

When using the Self-Service 2.0 plug-in in a roaming profile environment, during each logon, applications fail to synchronize automatically. Users must force application synchronization by using the settings and Refresh Applications option.

Refresh Application

The applications synchronize after the refresh task is completed. But the process must be repeated for each logon.

Note: Profile caching was not in use in the environment.

Solution

To resolve the issue, exclude the directory AppData\Roaming\Microsoft\Windows\Start Menu\Program Files from the roaming profile because it is a junction or a symbolic link and is not required to be copied to the profile. 

Problem Cause

Running a process monitor at logon reveals that the SelfService.exe is trying to create a file in the following directory:
AppData\Roaming\Microsoft\Windows\Start Menu\Program Files

Writing of this file is essential for the synchronization of the applications. But, the creation of this file is denied. Therefore, it interrupts the Self Service process and thus the Citrix Receiver application icon fails to populate correctly.
Process Monitor

Additional Resources

Application synchronization

Subscribed resources follow users from one computer with the Windows operating system to the other so that they need not repeatedly make the same changes each time they use a different computer with the Windows operating system. When a user adds, removes, renames, or moves a resource in a store with application synchronization enabled, details of the change are recorded in the store. Subsequently, whenever the user accesses the store from a different device running Citrix Receiver with the Citrix Self-service Plug-in for Windows, the same changes are automatically applied to the new device. This feature requires Delivery Services.

Refer to the Knowledge Center article CTX124932 – How to Configure Dazzle for Use with XenDesktop and Provisioning Services for more information.

Applicable Products

Automatic translation

Important: This article was translated by an automatic translation system (also referred to as Machine Translation, or MT) and has not been translated or reviewed by people. Citrix offers a machine translated version of this article to allow for greater access to the support content. However, automatic translation is not always perfect and may contain errors of vocabulary, syntax or grammar. Citrix is not responsible for inconsistencies, errors or damage incurred as a result of the use of MT articles from our customers.Thank you.
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