Citrix

Error: 'Internet Explorer cannot display the webpage' or 'Secure Connection Failed' when using Citrix Access Gateway 4.6.x Standard Edition and SSL Client Certificates

  • CTX124234
  • Created On  Mar 11, 2010
  • Updated On  Mar 11, 2010
  • 7 found this helpful
  • Article
  • Topic : Licensing

Symptoms

When users enter the URL of the Citrix Access Gateway (either using Internet Explorer or Firefox browser), they are prompted for an SSL Client Certificate. After submission, they receive the following error message:

From Internet Explorer:

“Internet Explorer cannot display the webpage”

From Firefox browser:

“Secure Connection Failed”

This article describes the common problems when using Citrix Access Gateway 4.6.x Standard Edition and SSL Client Certificates.

Cause 1

The SSL Client Certificate is not installed on the user’s workstation browser.

Cause 2

The root certificate of the certificate authority server that issued the client certificate is not uploaded on the Citrix Access Gateway Standard Edition appliance.

Resolution 1

From the Client Workstation

Import l a User Certificate (in .P12 format).

Example:

Using Internet Explorer 8 browser, you can import the SSL Client Certificate(s) under Internet Options > Content > Certificates > Personal tab.

Using Firefox browser 3.5.x or 3.6.x, you can import the SSL Client Certificate(s) under Tools > Advanced > Encryption > View Certificates > Your Certificates tab.

Resolution 2

From the Citrix Access Gateway 4.6.x appliance

1. Open the Citrix Access Gateway Administration Tool > select This Gateway > select the Administration tab > click on Manage under Manage trusted root certificates.

2. Upload the root certificate for the certificate authority that issued the client certificate(s).

Note: Make sure the root certificate conforms to the Base64 file format.

3. Reboot the Citrix Access Gateway appliance.


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