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Archive: Error: Your current browser security settings may prevent you from accessing your published resources

  • CTX122012
  • Created On  Feb 04, 2010
  • Updated On  Mar 10, 2012
  • 23 found this helpful
  • Article
  • Topic : Configuration
This article is no longer maintained, its content refers to a discontinued product and may be out of date. Refer to the Discontinued Product Lifecycle or Active Citrix Product pages for more information on support schedules.

Symptoms

You receive the following error message:

“Your current browser security settings may prevent you from accessing your published resources”

Cause

Web Interface displays this message when a user is accessing the site over a secure (HTTPS) connection and Internet Explorer has put it in the Internet Zone.

The reason for displaying the message is an Internet Explorer setting called Do not save encrypted pages to disk. Some companies enable this setting on their users' browsers for security reasons. Unfortunately, if this setting is turned on, then the standard Web Interface mechanism for launching applications (downloading an ICA file to the user) does not work.

Workaround

You can eliminate this message by either changing Internet Explorer settings or by modifying Web Interface.

Workaround 1 – Change Internet Explorer Settings and leaving the setting enabled

Change Internet Explorer Settings

  1. Open Internet Explorer.
  2. Browse to the Web Interface site.
  3. On the menu bar go to Tools > Internet Options.
  4. Click on the Security tab.
  5. Under Select a zone to view or change security settings, click Trusted sites.
  6. Click Sites.
  7. The Web Interface URL should appear under Add this website to the zone. Click Add to add the site into the Trusted sites security zone.
  8. Click OK to close the window and initiate the changes.

Workaround 2 – Change Internet Explorer Settings by disabling the setting

  1. Open Internet Explorer.
  2. On the menu bar go to Tools > Internet Options.
  3. Click on the Advanced tab.
  4. Scroll through the list to the Security section at the bottom.
  5. Select the box next to the option Do Not Save Encrypted Pages To Disk.
  6. Click OK to close the window and initiate the changes.

Note: Make sure all Temporary Internet Files and Cookies are deleted, and the browser is re-launched before testing changes.

Note: These settings can also be pushed by a client GPO.

Workaround 3 – Modify the MessageUtils.java file

For Web Interface 4.6

  1. You can disable this message by editing the messageCenterView.ascx file which appears twice inside each Web Interface site (both identical) and can be found in inetpub\wwwroote\Citrix\AccessPlatform\app_data\auth\include and inetpub\wwwroote\Citrix\AccessPlatform\app_data\site\include
  2. Open the file in a text editor.
  3. Comment out the following lines so that it looks like the following example:
    // messageCenterControl.setKey( "SaveLaunchFileToDisk" );
    // messageCenterControl.setType( MessageCenterControl.MSGTYPE_WARNING );

    Note
    : You must add // to beginning of the line.

For Web Interface 5.x

  1. Edit the file called messageUtils.java which can be found in the following location inetpub\wwwroot\Citrix\Xenapp\app_code\PagesJava\com\citrix\wi\controlutils
  2. Comment out the following lines so that it looks like the following example:
    // viewControl.addMessage(new MessageScreenMessage(MessageType.WARNING,
    // wiContext.getString("SaveLaunchFileToDisk"), wiContext.getString("SaveLaunchFileToDisk")));

    Note
    : You must add // to the beginning of the line.

Each method should stop Web Interface from displaying the message.

More Information

CTX126950 – 12.1 Online Plug-In - Issues Fixed in This Release

If the Windows Internet Explorer setting "Do not save encrypted pages to disk" is enabled on a workstation or a pass-through server, sessions fail to launch from the Web Interface. Instead, Internet Explorer prompts the user to save the file locally and, based on the operating system, the following error message might appear: "Cannot copy file: cannot read from the source file or disk." No error message appears on Windows 7 and on Windows Server 2008 and the file is not saved. [#236181]

CTX395275 – Error: ICA file not found


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