Citrix

Archive: Vulnerability in Access Gateway Standard Edition and Advanced Edition appliance firmware could result in authentication bypass

  • CTX116930
  • Created onMay 09, 2008
  • Updated onOct 08, 2014
Security Bulletin Severity High

This article is no longer maintained, its content refers to a discontinued product and may be out of date. Refer to the Discontinued Product Lifecycle or Active Citrix Product pages for more information on support schedules

Description of Problem

A vulnerability exists in Access Gateway that, in certain configurations, could allow unauthenticated access to network resources.

This vulnerability is present in all versions of the Access Gateway Standard Edition (up to and including 4.5.7) and Advanced Edition (up to and including 4.5 HF2).

Access Gateway Enterprise Edition is not affected by this vulnerability.

Mitigating Factors

Customers using the Access Gateway appliance in Access Gateway or Secure Gateway modes are not affected by this vulnerability.

Citrix recommends that customers with Internet-facing deployments implement strong authentication.

What Customers Should Do

This vulnerability has been addressed in Access Gateway Standard Edition appliance firmware version 4.5.7 Rev A.

Citrix strongly recommends that customers upgrade their appliance firmware to version 4.5.7 Rev A. This firmware upgrade can be obtained from the following location:

http://support.citrix.com/article/CTX116762

Customers using appliance firmware versions 4.5.5, 4.5.6 and 4.5.7 can apply a patch to their current appliance firmware to correct this vulnerability. Customers should be aware that applying these files could cause some custom software configurations to become non-functional.

The patch can be obtained from the following locations:

http://support.citrix.com/article/CTX117001

What Citrix Is Doing

Citrix is notifying customers and channel partners about this potential security issue. This article is also available from the Citrix Knowledge center at http://support.citrix.com/.

Obtaining Support on this Issue

If you require technical assistance with this issue, please contact Citrix Technical Support. Information for contacting Citrix Technical Support is available at http://www.citrix.com/English/ss/supportContacts.asp.

Reporting Security Vulnerabilities to Citrix

Citrix welcomes input regarding the security of its products and considers any and all potential vulnerabilities very seriously. If you would like to report a security issue to Citrix, please compose an e-mail to secure@citrix.com containing the exact version of the product in which the vulnerability was found and the steps needed to reproduce the vulnerability.

Was this helpful?
Thank you for your feedback

Share your comments or find out more about this topic

Citrix Forums