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Error: New Hardware Found

Document ID: CTX115423   /   Created On: Nov 26, 2007   /   Updated On: Jul 17, 2008
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Symptoms

When an Ardence client starts using a shared image with the Cache Type set for Cache on client hard drive, Windows may display the message "New Hardware Found" and prompt the user to re-start the client system. This message is often seen when the client's hard drive differs from the hard drive of the Master Client used to build the initial vDisk image.

This article applies to clients running the following operating systems:

WinXP Pro SP2
Win2K Pro SP4

Cause

When a Windows operating system starts, it reads information from each installed hard drive to construct a volume ID, per volume, consisting of several components including the Master Boot Record (MBR) signature, partition size, and offset. Each time the operating system starts it compares the volume IDs with the signatures stored in the registry to ensure it has seen each volume before (see key HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices). If the operating system is unable to find a match for a particular volume, it classifies the event as new hardware found, adds the device to the machine configuration, adds the volume ID to Mounted Devices and prompts the user to reboot the system to allow the Plug and Play service to deal with the newly discovered hardware.


Note:
Other factors, including different drive geometry, partition table type, disk drive type (SATA, SCSI, IDE), can also trigger the "New Hardware Found" message.

Resolution

The batch script Update_MBRSig.bat discussed here covers the majority of the hard drive differences described in the previous paragraphs and is hard-coded to deal with only one drive - hard drive0. When run, the batch script performs a one-time write of the Master Client's signature; modifying the signature of hard drive0 in the client to the well-known signature 0xf000000f. Use this batch script to as defined below.

Procedure to update the Master Client:

1. Log onto the Ardence Support Portal. Select Downloads under Ardence Subscription Services and select MbrSig.

2. Extract the contents of the MbrSig.zip file attached to this article to a temporary folder on the Master Client.

3. Shutdown all clients connected to the vDisk requiring modification.

4. In the Ardence Administrator, change the vDisk Disk Access Mode to Private Image.

5. Start the Master Client (the client used to build the original vDisk image) using the vDisk requiring modification.

6. Log onto the client as the Local Administrator and copy the MbrSig.exe and Update_MBRSig.bat files to the Ardence software folder.

7. Open a DOS shell and run the Update_MBRSig.bat script. The script will save the original signature in the file <windir>\MBR_OrigSig.txt and overwrite the existing signature with the 0xf000000f signature.

8. Edit the registry to allow AutoAdminLogon to automatically log on as the Default User Name with the Default User Password upon startup.

9. Add the Update_MBRScript.bat to the All_Users/Startup folder.


Note:
Remember to assign a temporary password as the Local Administrator password because the registry will expose the password in clear text. Also, remember to select a user that has local administrative rights to the image.


10. Reboot the Master Client to allow the Windows operating system to record the new disk signature in the directory and store the new data in the registry.

11. Shut down the Master Client.

12. In the Ardence Administrator, change the vDisk Disk Access Mode to Standard Image.

13. Re-start all clients that are going to use the vDisk image so that they log on using the AutoAdminLogon account to automatically run the script to update their hard drive signatures.


Note
: This step obliterates the local drive signatures since they cannot be stored on either the hard disk or the write-protected vDisk shared image.


14. Remove the MbrSig.exe and Update_MBRSig.bat files.

15. Restore the Local Administrator password modified in step 8.

If some clients continue to receive the "New Hardware Found" message after performing the procedure described above, it will necessary to reset the vDisk Disk Access Mode to Private Image and extend the image to contain the new drivers and settings for the different types of hardware discovered in those clients.

Note: The size of the vDisk image will increase and may take longer to load and initialize.

Procedure to update a shared image:

1. Shutdown all clients connected to the vDisk requiring modification.

2. In the Ardence Administrator, change the vDisk Disk Access Mode to Private Image.

3. Start one of the clients still displaying the “New Hardware Found” message using the vDisk requiring modification.

4. Log on as the Local Administrator and allow the operating system to complete the boot cycle, update its drivers, and record new data in the registry.

5. Shut down the client.

6. In the Ardence Administrator, change the vDisk Disk Access Mode to Standard Image.

Removal of AutoAdminLogon from the shared image:

Once the installation has stabilized, remove the AutoAdminLogon setting from the shared image by performing the following steps:

1. Shutdown all clients connected to the modified vDisk.

2. In the Ardence Administrator, change the vDisk Disk Access Mode to Private Image.

3. Start the Master Client (the client used to build the original vDisk image) using the modified vDisk.

4. Edit the registry setting that enabled AutoAdminLogon and set the auto logon to false (HKLM\Software\Microsoft\Windows NT\CurrentVersion\winlogon\AutoAdminLogon=0).

Note: The AutoAdminLogon user and password may also be removed from the shared image.

5. Remove the Update_MBRSig.bat file from the All_Users/Startup folder.

6. Shut down the Master Client.

7. In the Ardence Administrator, change the vDisk Disk Access Mode to Standard Image.

More Information

For more information on the auto logon registry keys, visit the following URL:

http://www.computerperformance.co.uk/Registry/registry_hacks_AutoAdminLogon.htm


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