Symptoms
There are many symptoms that may indicate that your antivirus software is interfering with the normal operation of the EdgeSight Server. The following list describes a few symptoms that may indicate a configuration change to your antivirus software is necessary.
• Payload processing stops or is very slow
• EdgeSight Server general performance is slow
• There are system or application Event Log entries indicating that EdgeSight server processes RSshApp.exe or RSshSvc.exe are crashing
• The Server Script Host continues to fail

Cause
The EdgeSight Server is very active, servicing EdgeSight Agent requests and requests from EdgeSight end users and administrators. Its architecture consists of many critical parts that are not very tolerant to continuous antivirus scanning or monitoring.
The components are:
• The EdgeSight Web site (an Internet Information Services (IIS) Web site)
• The SQL Server
• The EdgeSight Server Script Host
• Reporting Services, which is also an IIS Web site
Your antivirus software must be configured to exclude the monitoring of these critical components.
Resolution
Configure your antivirus software (Trend Micro, Symantec, Norton, McAfee, and so on) to ignore the important EdgeSight processes and files. This should be done on all the devices that are or will be running an EdgeSight Server. You may need to contact your security administration team to enforce these exceptions.
WARNING! You must NOT be running McAfee 8.0 with patch 10. If so, you MUST install patch 11 or later before installing the EdgeSight Agent.
1. Exclude the EdgeSight Server Script Host processes and folders. The Server Script Host is a scripting engine that runs scripts to load data into the EdgeSight database as well as to maintain it. The folder names listed below are the default (yours may differ based on your actual installation):
<root directory>\Program Files\Common Files\Citrix\System Monitoring\Server\RSSH
Note: The most important exceptions are the RSshApp.exe and RSshSvc.exe executables in this folder.
<root directory>\Program Files\Citrix\System Monitoring\Server\EdgeSight 4.0\scripts\rssh
2. Exclude the EdgeSight Web site:
<root directory>\Program Files\Citrix\System Monitoring\Server\EdgeSight 4.0\Pages
3. Exclude the Microsoft Reporting Services Web site:
<root directory>\Program Files\Microsoft SQL Server\MSSQL\Reporting Services
4. Exclude the SQL Server database itself. By default, it is located in the folder listed below. Consult your database administrator for the exact location.
<root directory>\Program Files\Microsoft SQL Server\MSSQL\Data
More Information
CTX111062 – Required Antivirus Software Configuration for the EdgeSight Agent