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Error: Internet Explorer cannot download icaweb32.msi

Document ID: CTX114716   /   Created On: Dec 6, 2007   /   Updated On: Apr 28, 2008
Average Rating: 5

Symptoms

When trying to install the Citrix ICA Web Client using Web Interface 4.6.x that is installed on an Advanced Access Control 4.5 Server, you receive the following error message:

"Internet Explorer cannot download icaweb32.msi”

The issue does not occur when the Web Interface and the Advanced Access Control are installed on separate servers.

Environment

• Advanced Access Control 4.5

• Web Interface (installed on same server as Advanced Access Control)

For Web Interface 4.6, follow the steps in CTX114097 – Deploying the Web Client 10.1 for Windows Through Web Interface 4.6 to deploy the Web Client 10.1 or later.

Cause

Advanced Access Control installs an ISAPI filter (WebProxyFilter) that, for security purposes, modifies the response headers coming in. Because Advanced Access Control installs this filter in the Web Sites folder at the top of the hierarchy in the Web server, it is applied to all sites (thus affecting the Web Interface). The filter sets the Cache-control property of the response header to no-store, ensuring that the cache does not store any part of the response. This results in the launch.ica file not being cached. When trying to launch the launch.ica file, Wfica32.exe does not find the file and returns the "ICA file not found" error message.

tp://support.citrix.com/article/html/images/CTX112128-2.gif

Workaround

Caution! This fix requires you to edit the registry. Using Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

If the Web Interface cannot be installed on a separate server, a workaround exists involving a registry exception list used by Advanced Access Control to exclude URLs from the filter. The exception list is located under:

HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\MSAM\FilterCacheControl

1. Create a key under FilterCacheControl with the location of the Web Interface site and its .ica file:

/Citrix/MyWISite/Clients_common/ica32/ica32web.msi (Example)

Note: The above path is case-sensitive.

2. Create a string within the newly created key with the following name:

application/octet-stream (screen shot below)

3. Run iisreset from the command prompt to ensure all Internet Information Services (IIS)-related services restart. If restarting from IIS Administration, ensure that it is done from the top level and not on any individual site.

More Information

See the related article CTX112128 - Error: "ICA File Not Found" ... When Launching Applications From a Web Interface Site on a Server with Advanced Access Control 4.5 when Launching Applications From a Web Interface Site on a Server with Advanced Access Control 4.5.


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