Rate this Article:
You must be signed in to rate again
Article Feedback Print View
Alternate Languages: N/A

Presentation 4.5 MSI Log Error: CtxComPlusAppRegister failed with error code 1603

Document ID: CTX114691   /   Created On: Dec 4, 2007   /   Updated On: Jan 17, 2008
Average Rating: not yet rated

Symptoms

The Citrix Presentation Server 4.5 installation terminates prematurely with the following error message:

"Installation ended prematurely because of an error."

When doing checking the Microsoft Installer (MSI) log file you can find following lines:

"MSI (s) (6C:40) [13:37:23:361]: Invoking remote custom action. DLL: F:\WINDOWS\Installer\MSI48C.tmp, Entrypoint: CtxComPlusAppRegister
Unknown exception
CtxComPlusAppRegister failed with error code 1603

Action ended 13:37:23: InstallFinalize. Return value 3.
MSI (s) (6C:F4) [13:37:23:673]: User policy value 'DisableRollback' is 0
MSI (s) (6C:F4) [13:37:23:673]: Machine policy value 'DisableRollback' is 0"

Cause

There is a problem with the .NET Framework as there is an unknown exception.

Resolution

See CTX113639 – The Citrix Presentation Server 4.5 Installation Effectively Hangs.

-Or-

Run a Repair of the .NET Framework in Add or Remove Programs.

-Or-

1. Uninstall the .NET Framework.

2. Install Presentation Server 4.5 using the autorun feature . This installs a fresh copy of the .NET Framework 2.0 from the Presentation Server 4.5 media.


This document applies to:

Search
Knowledge Center
XenApp
XenApp Plugins (Clients)
XenServer
XenDesktop
NetScaler Application Delivery
Access Gateway
EdgeSight
Provisioning Server
WANScaler
Password Manager
Does it work with Citrix? Verify it - introducing the new Citrix Ready Community Verified