[タイトル]
Citrix Presentation Server 4.5 64-bit EditionでのAccess管理コンソールのエラー
[現象]
以下のイベントログが記録されたり、Service Pack 1を適用した64bit版Windows Server 2003で実行されているPresnetaion Server 4.5 for Windows Server 2003 x64でAccess管理コンソールを使用した検出の実行中にエラーメッセージが表示されたりします。
イベントログに以下のメッセージが記録されます。
「COM+ System Applicationサービスは次のエラーのため開始できませんでした:そのサービスは指定時間内に開始要求または制御要求に応答しませんでした。」
Access管理コンソールで検出の実行中に以下のメッセージが表示されます。
「検出プロセスで<サーバー名>を使用するときにエラーが発生しました。MFCOM Serviceが正しく応答しません。リモートサーバーに接続している場合は、ユーザーアカウントがこのコンピュータのDistributed COM Usersグループのメンバであることを確認してください。コンピュータにインストールされているCitrix Presentation Serverのバージョンを確認し、互換性のあるバージョンのCitrix MFCOM Serviceがインストールされ、動作していることを確認してください。」
[コンポーネントサービス]で[マイコンピュータ]を選択した後[すべてのコンポーネントの更新]オプションを使用すると、次のエラーメッセージが断続的に表示されます。
「カタログエラー:
最後の操作の処理中にエラーが発生しました。エラー コード80040154 - クラスが登録されていません - イベントログにトラブルシューティングのための追加情報が含まれている可能性があります。」
[原因]
MicrosoftのCOM+サブシステムで断続的に発生する問題により、Presentation Serverのコンポーネントが正常にインストールされないことが原因であると考えられます。
[解決方法]
Presnetation Server 4.5 for Windows Server 2003 x64またはPresentation Server4.0 for Windows Server 2003 x64を実行しているサーバーに、Windows Server 2003 Service Pack 2をインストールします。
Windows Server 2003 Service Pack 1上でPresentation Server 4.0 x64を実行しており、Presentataion Server 4.5 x64へのアップグレードを計画している場合は、Windows Server 2003 Service Pack 2を適用したあと、以下の手順を行ないます。
1. COM+に関する問題が発生していないかどうか、イベントログにエラーが記録されていないかどうかを確認します。
2. COM+ Event SystemおよびCOM+ System Applicationサービスが有効になっているかどうか確認します。
[追加情報]
Windows Server 2003 Service Pack 2の更新の一覧
CTX113062 – Microsoft Windows Server 2003 Service Pack 2に関する既知問題
CTX113055 – Presentation Server 4.5 64-bit Editionのインストール後、検出プロセスの実行中にAccess管理コンソールでエラーが発生する
CTX108419 – MFCOMのアクセスセキュリティの設定
[関連情報]
この資料は米国のCitrix Knowledge Baseで提供している情報をもとに作成したものです。
Document ID: CTX113115
Access Management Console Errors in Citrix Presentation Server 4.5 64-bit Edition