Symptoms
The following error message is received when using an HTTPS URL to download the Citrix Web Client for Windows through Web Interface 4.6:
Internet Explorer cannot download icaweb.msi from TestSite.citrix.com
Internet Explorer was not able to open this Internet site. The requested site is either unavailable or cannot be found. Please try again later.
Reproduction Steps
1. Configure your Web Interface site to use SSL.
2. Configure Web Interface to deploy the Web client for Windows to users.
3. Bring up your browser and access the URL of your Web Interface site using SSL; for example, https://TestSite.citrix.com.
4. Log on or click the link to download the client. The client attempts to deploy, but hangs on clientdetection/nativeClientDownloades.aspx.
5. Adding the site as a trusted site does not resolve the issue.
6. If HTTP is used to access the site, the client deploys fine.
Cause
The Do not save encrypted pages to disk check box is selected in Internet Explorer 6.0 SP1.
Workaround
Clear the Do not save encrypted pages to disk check box.
More Information
CTX114097 - Deploying the Web Client 10.1 for Windows Through Web Interface 4.6