Summary
Despite setting the Session Reliability timeout to five minutes in the management consoles (Access Management Console and/or Presentation Server Console), client sessions timeout after three minutes (the default setting).
Cause
By design, the client's Session Reliability setting overrides the server's setting.
Resolution
For version 9.x of the Presentation Server Client:
1. Open the \Documents and Settings\<user name>\Application Data\ICAClient\AppSrv.ini file in a text editor.
2. Add the following line under the [WFClient] section:
SessionReliabilityTTL=<the desired timeout value in seconds>
Note: The default value is 180 seconds.
For version 10.x of the Presentation Server Client:
WARNING! Using Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk.
Create the following value under the HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\ICA Client\Engine\Configuration\Advanced\Modules\WFClient key:
Type: REG_SZ
Name: SessionReliabilityTTL
Value data: <the desired timeout value in seconds>
More Information
CTX104147 – Explaining ICA Session Reliability, Common Gateway Protocol, on TCP Port 2598