Symptoms
You experience the following symptoms:
Refer to the following screen shot:

Cause
Initial analysis seems to indicate that one or more of the rotatelogs.exe processes has terminated or is being used by another application that also uses Apache (for example, hpsmhd.exe). There should be five rotatelogs.exe processes running.
Note: Citrix Technical Support manually terminated all file rotatelogs.exe processes as a test. The Secure Gateway Service could not be restarted without restarting the server.
Workaround
Restart the Secure Gateway Service and/or the entire server.
Resolution
Complete the procedure described in CTX110896 – Secure Gateway 3.0 Service Initialization Hangs - Users Cannot Connect Unless the Service is Manually Restarted.
More Information
CTX110845 – Explaining -k runservice and the Appearance of Two XTE.exe or CtxSGSvc.exe Executables in Task Manager
CTX107583 – Automatic Cleanup of Log Files by Rotatelogs in Secure Gateway 3.0
CTX107581 – Secure Gateway 3.0 Configuration File - httpd.conf