Symptoms
You are not prompted for a PIN when launching an ICA session while using a smart card on the client system.
This occurs despite the fact that the Smart card radio button is selected on the Logon Information tab in the Presentation Server Client.

During an RDP logon to a server running Windows Server 2003, you are prompted for a PIN.
Cause
There is no smart card hook enabled on the registry of the server. By default, the value is present. However, it may have been disabled for troubleshooting purposes.
Resolution
WARNING! Using Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk.
1. Ensure that the HKEY_LOCAL_MACHINE\software\citrix\ctxhook\appinit_dlls\smart card hook registry key contains scardhook.dll and that the scardhook.dll file is present in the \Program Files\Citrix\System32 directory.

2. Ensure that mfaphook is not disabled as per CTX107824 – Citrix API Hooks (mfaphook.dll) Explained and Enumerated. Mfaphook enables the smart card hook.