Symptoms
You receive the following error message:
"The Citrix Presentation Server Client for 32-bit Windows could not be deployed automatically. Please contact your administrator. Log ID: 46dc6b66"
Note: The Log ID may vary.
Refer to the following screen shot:

Event ID 0 may be logged in the Event Viewer Application log. For example:
"Source: Web Interface at c:\inetpub\wwwroot\Citrix\AccessPlatform
The Citrix Presentation Server Client for 32-bit Windows setup files could not be located on the server. Please ensure that the client files have been copied to the correct location. [Log ID: 46dc6b66]"
This issue may occur on a Web Interface site or on a Web Interface site integrated with Advanced Access Control. This issue may be more prevalent when upgrading from an earlier Web Interface version if the later version contains a new client directory path.
Cause
The Web Interface site is configured to deploy the client, yet the clients are not installed in the client directory.
For example, Web Interface 4.5 stores the clients in the following location: \Inetpub\wwwroot\Citrix\AccessPlatform\Clients

Resolution
Consult the appropriate Web Interface, Advanced Access Control, or other knowledge base articles to determine which client directory must be updated. In addition, the Install Caption section can be used to download the client from Citrix.com.
More Information
CTX112732 – How to Deploy the ICA Web Client Through Web Interface 4.5
CTX112727 – Access Gateway Enterprise Edition Quick Installation and Configuration
CTX110866 – Error: The MetaFrame Presentation Server Client for Java files could not be located on the server