Symptoms
In some environments where multiple domains and multiple trusts exist, the installation of Citrix Presentation Server 4.5 appears to hang when the "Citrix is Installing Product Components" message is displayed.
The installation completes successfully if left for a period of 15 hours or more.
Cause
This issue occurs when multiple domains and multiple trusts exist within the environment where Presentation Server 4.5 is being installed. A delay is incurred by account resolution during the COM+ components installation, which forms part of the installation process.
Resolution
The installation transform file attached to this article can be used in environments experiencing this issue.
To use the transform file, launch the Presentation Server 4.5 installation using the following command:
msiexec.exe /i "D:\Citrix Presentation Server\mps.msi" TRANSFORMS="c:\temp\CTXUpdate.mst" /l*v c:\temp\mps.log
Where D:\Citrix Presentation Server is the correct path to the MPS.msi file and C:\temp is the correct path to the CTXUpdate.mst transform file.
Issue the following command if an unattended installation is necessary:
UnattendedInstall.exe <path-to-mps.msi> <answer_file.txt> [MSIPROPERTY1=”VALUE1”]
Where MSIPROPERTY1 = TRANSFORMS and VALUE1 = <path to CTXUpdate.mst>
Additionally, verify the validity of all trusts within the environment.
More Information
CTX114691 – Presentation 4.5 MSI Log Error: CtxComPlusAppRegister failed with error code 1603
When this issue occurs, the following may be seen in the Microsoft Installer (MSI) log:
MSI (s) (D0:A8) [15:58:40:295]: Executing op: CustomActionSchedule
(Action=CtxComPlusAppRegisterRB.E289452F_B008_4882_ABB2_77E22692D9C4,ActionType=3329,
Source=BinaryData,Target=CtxComPlusAppRegisterRB,CustomActionData=
CitrixLogServer.E289452F_B008_4882_ABB2_77E22692D9C4
=key_app_name=CitrixLogServer
key_type=2
key_component=M:\Program Files\Citrix\System32\CitrixLogServer.dll
component_tlb=M:\Program Files\Citrix\System32\CitrixLogServer.tlb
component_psdll=
component_install_state=2
component_action_state=3
key_role=__all
role_install_state=2
role_action_state=3
key_user=networkservice
user_domain=nt authority
key_property=Identity
property_value=nt authority\networkservice
property_type_value=6)
MSI (s) (D0:A8) [15:58:40:310]: Executing op: ActionStart(Name=CtxComPlusAppRegister.E289452F_B008_4882_ABB2_77E22692D9C4,,)
Action 15:58:40: CtxComPlusAppRegister.E289452F_B008_4882_ABB2_77E22692D9C4.
MSI (s) (D0:A8) [15:58:40:342]: Executing op: CustomActionSchedule
(Action=CtxComPlusAppRegister.E289452F_B008_4882_ABB2_77E22692D9C4,
ActionType=3073,Source=BinaryData,
Target=CtxComPlusAppRegister,
CustomActionData=
CitrixLogServer.E289452F_B008_4882_ABB2_77E22692D9C4
=key_app_name=CitrixLogServer
key_type=2
key_component=M:\Program Files\Citrix\System32\CitrixLogServer.dll
component_tlb=M:\Program Files\Citrix\System32\CitrixLogServer.tlb
component_psdll=
component_install_state=2
component_action_state=3
key_role=__all
role_install_state=2
role_action_state=3
key_user=networkservice
user_domain=nt authority
key_property=Identity
property_value=nt authority\networkservice
property_type_value=6)
Additionally, you can monitor the progress of the COM+ components installation by launching the Component Services tool from the Administrative Tools menu and then expanding Component Services > Computers > My Computer > Distributed Transaction Coordinator > Transaction Statistics.
Each component takes two minutes to complete on average.
For more information on unattended installations, refer to CTX112223 – Citrix Presentation Server 4.5 Administrator's Guide.