Rate this Article:
You must be signed in to rate again
Article Feedback Print View
Alternate Languages:

Access Management Console Errors in Citrix Presentation Server 4.5 64-bit Edition

Document ID: CTX113115   /   Created On: May 1, 2007   /   Updated On: Oct 31, 2007
Average Rating: 5

Symptoms

The following error messages might appear in the Event Log or while running discovery using version 3.0 of the Access Management Console on servers running Presentation Server 4.5 64-bit Edition for Windows Server 2003 with Service Pack 1.

In the Event Log: "The COM+ System Application service failed to start due to the following error: The service did not respond to the start or control request in a timely fashion."

In the Access Management Console: "Errors occurred when using <server name> in the discovery process. Citrix MFCOM Service did not respond as expected. Make sure that your user account is a member of this computer’s Distributed COM Users group if you are connecting to a remote server. Check the version of Citrix Presentation Server on the computer and ensure that a compatible version of Citrix MFCOM Service is installed and running."

Using the Refresh all components option after selecting My Computer in Component Services may intermittently produce the following error:

"Catalog Error:
An Error occurred while processing the last operation error code 80040154-class not registered-The event log may contain additional information"

Cause

This issue may be caused by an intermittent flaw in Microsoft’s COM+ subsystems that prevents the proper installation of Presentation Server components.

Resolution

Install Service Pack 2 for Windows Server 2003 on the server running Presentation Server 64-bit (4.0 or 4.5).

If you are running Presentation Server 4.0 64-bit on a server running Windows Server 2003 Service Pack 1 and plan to upgrade to Presentation Server 4.5 64-bit, complete the following procedure after applying Service Pack 2:

1. Verify that you do not have any COM+ issues or errors in the Event Log.

2. Verify that the COM+ Event System and COM+ System Application services are enabled.

More Information

Microsoft Knowledge Base article 914962

CTX113035 – Known Issues with Service Pack 2 for Windows Server 2003

CTX113117 – The Access Management Console Fails During the Discovery Process After Installing Presentation Server 4.5

CTX106303 – Configuring MFCOM Access Security


This document applies to:

  • Access Gateway 4.5 Standard Edition
  • Presentation Server 4.5 for Windows Server 2003 x64 Edition
Search
Knowledge Center
Presentation Server
Presentation Server Clients (ICA)
XenServer
XenDesktop
NetScaler Application Delivery
Access Gateway
EdgeSight
Provisioning Server
WANScaler
Password Manager
Citrix Developer Community