[タイトル]
ポリシーでクライアントプリンタの自動作成が無効になっているにもかかわらず、セッションに再接続するとCitrix Print Managerサービスの再起動後にクライアントプリンタが自動作成される
[現象]
Citrix管理コンソールで設定したポリシーでクライアントプリンタの自動作成が無効になっているにもかかわらず、セッションに再接続するとCitrix Print Managerサービスの再起動後にクライアントプリンタが自動作成されます。
[原因]
これは仕様です。Presentation Server 4.0では、プリンタ関連のすべてのポリシーはログオン時にのみ適用され(ポリシーは、Citrixサーバーごとに設定可能なICAリスナー上の設定より優先されます)、自動作成が無効になっている場合、プリンタは一切自動作成されません。
したがって、その後Citrix Print Managerサービスを再起動すると、プリンタが再検出されます。それにより、Microsoft Print Spoolerサービスが通知を受け取り、サーバーのレジストリを更新します。仕様上、プリンタ関連のポリシーは再接続時に適用されないようになっているため、レジストリから検出された新しいプリンタが自動作成されます。
[回避策]
Presentation Serverの[Citrixコネクション構成ツール]で、ICAリスナーに対して[Windowsクライアントのプリンタマッピングを無効にする]を選択すると、Citrix Print Managerサービスを再起動してもプリンタが自動作成されなくなります(Microsoft Print Spoolerサービスの呼び出しは影響しません)。
注:正常な実務環境では、通常Citrix Print Managerサービスを再起動する必要はありません。
[追加情報]
CTX108170 – Presentation Server 4.0 Printing Enhancements
[関連情報]
この資料は米国のCitrix Knowledge Baseで提供している情報をもとに作成したものです。
Document ID: CTX112159