現象
以下の問題が発生します。
• クライアントプリンタや割り当てられたネットワークプリンタが作成されないことがあります。エラーはイベントビューアに記録されません。この現象は、Print SpoolerサービスとCitrix Print Managerサービスを再起動すると一時的に解決します。
• 自動作成されたクライアントプリンタが、ユーザーのログオフ時に削除されません。
• 「Hpboid.exe」および「Hpbpro.exe」という名前の複数のプロセスがサーバーのタスクマネージャに表示されたまま、終了しません。
• Citrix Print Manager Service(cpsvc.exe)のスレッド数が、このサービスを再起動するまで増え続けます。
• Print Spoolerサービスが停止します。
• イベントログにイベントID 1116が記録されます。「プリンタの自動作成に失敗しました。理由: AddPrinter() がステータス0x709で失敗しました。\r\nクライアント名 :....」
• 科学計算用電卓を仕様して、16進法値の709を10進法値収率の1801へ変換してから、net helpmsgコマンドを実行すると、以下のメッセージが返されます。
C:\Documents and Settings\Administrator>net helpmsg 1801
名前が無効です。
原因
Presentation Serverの自動作成プリンタおよび割り当てられたネットワークプリンタの機能では、MicrosoftのPrint Spoolerサービスを使ってプリンタを作成します。Print SpoolerがCitrix Print Managerサービスまたはwfshell.exe(Presentation Server 4.0より以前のバージョンの場合)からの要求に応答しないと、プリンタの作成に失敗します。
Citrixでは、以下のプリンタドライバでPrint Spoolerサービスが停止したり応答しなくなったりするという問題を引き起こす可能性があることを確認しました。
注:以下のドライバの一部には、Windowsオペレーティングシステムに付属しているバージョン(ネイティブドライバ)があります。これらのWindowsに付属しているドライバでは、この問題は発生しません。各ドライバで問題が発生するかどうかについては、[追加情報]を参照してください。
• HP Color LaserJet 2500
• HP Color LaserJet 2800 Series
• HP Color LaserJet 3000
• HP Color LaserJet 3550
• HP Color LaserJet 3600
• HP Color LaserJet 3700
• HP Color LaserJet 3800
• HP Color LaserJet 4550
• HP Color LaserJet 4600
• HP Color LaserJet 4650
• HP Color LaserJet 4700
• HP Color LaserJet 4730 MFP
• HP Color LaserJet 5500
• HP Color LaserJet 5550
• HP Color LaserJet 8550
• HP Color LaserJet 9500
• HP Color LaserJet 9500 MFP
• HP LaserJet 2300
• HP LaserJet 2410/2420/2430
• HP LaserJet 4100
• HP LaserJet 4200
• HP LaserJet 4250
• HP LaserJet 4300
• HP LaserJet 4345 MFP
• HP LaserJet 4350
• HP LaserJet 5100
• HP LaserJet 5200/5200L
• HP LaserJet 8150
• HP LaserJet 9000
• HP LaserJet 9050
• HP LaserJet 9050/9040 MFP
• HP LaserJet 9055 MFP
• HP LaserJet 9065 MFP
回避策
注:この解決方法ではレジストリの編集が必要になります。レジストリエディタの使用を誤ると、深刻な問題が発生する可能性があり、Windowsの再インストールが必要になることがあります。レジストリエディタは自己の責任と判断の範囲でご使用ください。また、レジストリを編集する前に、レジストリファイルのバックアップを作成してください。
これらの現象がサーバーに影響するかどうかの確認、またこれらの現象を回避するには、次の手順を完了してください。
1. Windows\System32\spool\drivers\w32sx86\3ディレクトリにあるhpbmini.dllおよびhpcdmc32.dllのファイル名を変更します。
2. レジストリキーHKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86\Drivers\Version-3\<ドライバ名>のDependentFiles値からhpbmini.dllファイルを削除します。
注:上記のドライバのネイティブバージョン(Windowsオペレーティングシステムに付属のバージョン)には、これらのファイルは含まれていません。
解決方法
プリンタドライバの最新バージョンを使用します。これにより、最新版のhpbmini.dllファイルおよびhpcdmc32.dllファイルの使用が確実になります。
サポートされているHPプリンタの一覧について、詳しくはCTX110571 – HP Printers Supported in Citrix Presentation Server Environmentsを参照してください。
―またはー
サードパーティ社製のドライバをインストールしないようにします。互換性のあるネイティブドライババージョン(例:HP LaserJet 4など)を割り当てます。
2005年6月以降に更新または公開されたHP製ドライバでは、上記の問題は修正されています。できるだけ最新版プリンタドライバを使用することがベストプラクティスです。
CTX112580 - Case Study: Intermittent Client Printer Creation and Deletion Failures
関連情報
この資料は米国のCitrix Knowledge Baseで提供している情報をもとに作成したものです。
Document ID: CTX111947
Intermittent Client Printer Autocreation Failures