Symptoms
No printers are autocreated in ICA sessions when using version 9.4 of the Java Client and native printer drivers.
The following event is logged on the Presentation Server:
Event 1106 "Client printer auto-creation failed. The driver could not be installed. Possible reasons for the failure: The driver is not in the list of drivers on the server. The driver cannot be located. The driver has not been mapped. Client name: (WI_iMjZEqy7HtNhJekLK) Printer: (HP LaserJet 4100 Series PCL (from WI_iMjZEqy7HtNhJekLK) in session 3) Printer driver: ()"
Cause
The Sun Java Print application programming interface (API) does not permit the printer autocreation. This API allows the Java Client to enumerate the printer names installed on the local machine but does not expose the print driver. During the autocreation process, the printing subsystem on the Presentation Server checks the printer name on the client and its driver.
By default, the Java Client associates the autodetected printer names with the Presentation Server or Printer Command Language (PCL) universal drivers.
To autocreate printers, the client must send the printer name and the printer driver. The interesting part of the event logged is Printer driver(), which shows that the server received an empty driver.
When the Universal Print Driver (UPD) is enabled through policies, the printer creation process falls back to it.
Workarounds
The following three workarounds are available if you must use the Java Client:

More Information
Refer to pages 45-49 of CTX106470 – Client for Java Administrator's Guide - Version 9.x.
Also see CTX104692 – Only Autocreate Client Default Printer... Option with Java Client 8.x and Later is Not Working.