Symptoms
Print jobs from published applications take an abnormally long time to finish in Windows Server 2003.
Cause
This problem occurs because the print spooler waits for a Windows Explorer window to display a print notification. The print spooler waits even though the notification does not appear when Windows Explorer is not running.
Resolution
A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in Microsoft article 924663. Only apply it to systems that are experiencing this specific problem.
Note: This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Citrix recommends that you wait for the next Windows Server 2003 service pack that contains this hotfix.
More Information
Refer to Microsoft Help and Support for a complete list of Microsoft product support services, telephone numbers, and information about support costs.