Symptoms
Client printers are autocreated at session reconnect after the Citrix Print Manager service is restarted even though autocreation has been disabled in a policy configured in the Citrix Management Console.
Cause
This is by design. In Presentation Server 4.0, any policy related to printing is applied/enforced (policies take precedence over settings configured on the ICA listener that can be set per Citrix server) at logon only and, if configured to disable autocreation, results in no printers being autocreated.
A subsequent restart of the Citrix Print Manager service causes the printers to be rediscovered. Then the Microsoft Print Spooler service is notified and it updates the server registry. Because the printing policies, by design, are not reapplied at reconnection, users receive the newly discovered printers from the registry.
Workaround
In the Citrix Connection Configuration Tool for the Presentation Server, disabling Windows Client Printer Mapping on the ICA listener results in no printers appearing for users even after restarting the Citrix Print Manager service (Microsoft Spooler calls have no effect here).
Note: In a well-maintained and fully functional production environment, there should be no need to restart the Citrix Print Manager service.
More Information
CTX108170 – Presentation Server 4.0 Printing Enhancements