Symptoms
The following issues are occurring:
• Periodically, client printers or assigned network printers fail to create. No error is logged in the Event Viewer. Restarting the Print Spooler and Citrix Print Manager services temporarily resolves the issue.
• Autocreated client printers are not deleted when users log off.
• Multiple processes titled “Hpboid.exe” and “Hpbpro.exe” run in the server's Task Manager and never terminate.
• The thread count of the Citrix Print Manager Service (cpsvc.exe) continues to rise and never decrements until the service is restarted.
• The Print Spooler service stops unexpectedly.
• Event ID 1116 appears in the Event Log. "Printer auto-creation failure. AddPrinter() failed with status 0x709. Client name ......"
• Using a scientific calculator, translating the hex value of 709 into decimal value yields 1801. Then, using the net helpmsg command returns the following message:
C:\Documents and Settings\Administrator>net helpmsg 1801
The printer name is invalid.
Cause
The autocreation and assigned network printer facility of Presentation Server depends on the Microsoft Print Spooler service to create printers. If the Print Spooler is unresponsive to requests from the Citrix Print Manager Service or wfshell.exe (prior to Presentation Server 4.0), printer creation fails.
Citrix has identified the following print drivers with problems that could cause the Print Spooler service to become unresponsive and/or stop unexpectedly.
Note: Some of the following drivers have versions that are included with the Windows operating system (native drivers). Native versions of these drivers do not exhibit this issue. See the More Information section to determine whether a particular driver may be affected.
• HP Color LaserJet 2500
• HP Color LaserJet 2800 Series
• HP Color LaserJet 3000
• HP Color LaserJet 3550
• HP Color LaserJet 3600
• HP Color LaserJet 3700
• HP Color LaserJet 3800
• HP Color LaserJet 4550
• HP Color LaserJet 4600
• HP Color LaserJet 4650
• HP Color LaserJet 4700
• HP Color LaserJet 4730 MFP
• HP Color LaserJet 5500
• HP Color LaserJet 5550
• HP Color LaserJet 8550
• HP Color LaserJet 9500
• HP Color LaserJet 9500 MFP
• HP LaserJet 2300
• HP LaserJet 2410/2420/2430
• HP LaserJet 4100
• HP LaserJet 4200
• HP LaserJet 4250
• HP LaserJet 4300
• HP LaserJet 4345 MFP
• HP LaserJet 4350
• HP LaserJet 5100
• HP LaserJet 5200/5200L
• HP LaserJet 8150
• HP LaserJet 9000
• HP LaserJet 9050
• HP LaserJet 9050/9040 MFP
• HP LaserJet 9055 MFP
• HP LaserJet 9065 MFP
Workaround
Caution! This fix requires you to edit the registry. Using Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.
To determine if these are issues affecting a server and for a workaround, complete the following procedure:
1. Rename the hpbmini.dll and hpcdmc32.dll files in the Windows\System32\spool\drivers\w32sx86\3 directory.
2. Remove the hpbmini.dll file from the DependentFiles registry entry under the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86\Drivers\Version-3\<driver> hive.
Note: Native (provided by the Windows operating system) versions of the above drivers do not include these files.
Resolution
Ensure you have the latest version of your printer driver. This ensures you have the latest versions of the hpbmini.dll and hpcdmc32.dll files. Refer to CTX110571 – HP Printers Supported in Citrix Presentation Server Environments for a list of supported HP printers.
-Or-
Alternatively, do not install these third-party drivers. Map to compatible native driver versions (such as HP LaserJet 4).
HP drivers updated and/or posted since June 2005 include the fixes for the above issues. It is a best practice to keep your printer drivers as current as possible.
See CTX112580 – Case Study: Intermittent Client Printer Creation and Deletion Failures.