Symptoms
You receive the following error message when trying to generate a report or chart from the License Management Console:
“Error: No charts generated
25-Sep-2006 12:48:25PM Error: In C:\Program Files\Citrix\Licensing\LS\reportlog.rl license server hostid changed from "xxxxxxxxxxxx" to yyyyyyyyyyyy. Hint: This report log may have been written to by multiple servers or vendor daemons. No further events will be read from this file.”
Cause
The Citrix license server’s Media Access Control (MAC) address is being used as a hostid to store license usage information into the reportlog.rl file defined within the Citrix.opt file. Refer to CTX106032 – How to Enable Report Logging with Access Suite Licensing 4.x for more information on report logging.
When the MAC address of the Citrix license server changes, the hostid also changes and results in multiple hostids being recorded in the same reportlog.rl file. This causes the license usage information written into the reportlog.rl file after the hostid change to be inaccessible.
Workaround
1. Specify a new reportlog.rl file (for example, reportlog1.rl) per CTX106032 – How to Enable Report Logging with Access Suite Licensing 4.x.
2. Restart the CitrixLicensing service in the Windows Service Control Manager.
3. Change the Citrix license server network card, network card teaming, or MAC address.
4. Verify the current hostid used by the license server by issuing the following command:
C:\Program Files\Citrix\Licensing\LS\lmhostid.exe
More Information
CTX106282 – Citrix Access Suite Licensing Guide
CTX103923 – Overview of MetaFrame Access Suite Licensing
CTX112955 – Reportlog.rl Files are No Longer Readable in the License Management Console