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Error: "HTTP Error 404 – File Or Directory Not Found" when Logging on to the EdgeSight Console

Document ID: CTX111779   /   Created On: Feb 15, 2007   /   Updated On: Nov 11, 2008
Average Rating: 4

Symptoms

When logging on to the console after installing the EdgeSight server, the following error message is received:

"The Page cannot be found.
The page you are looking for might have been removed, had its name changed, or is temporarily unavailable."

"HTTP Error 404 – File Or Directory Not Found. Internet Information Services (IIS)"

Note: The URL used by EdgeSight 4.x is http://<Server name>/edgesight40. The URL used by EdgeSight 5.0 is http://<Server name>/edgesight.

Failure to use the correct EdgeSight URL also produces the error above. Double-check the EdgeSight console URL by using another EdgeSight Web console (on another client computer) or by using the EdgeSight Web console on the EdgeSight server.

The solution below represents an unusual circumstance that causes the symptom above.

Cause

In some cases, ASP.NET 2.0 is not properly registered under Web Service Extensions (under the Internet Information Services (IIS) Manager). This can happen if you install ASP.NET 1.1 after installing 2.0, for example. You can validate this by opening the IIS Manager, and selecting Web Service Extensions. As shown in the following screenshot, ASP.NET 1.1 is listed, but not 2.0.

Resolution

1. Right-click within the Web Service Extensions window, and select Add a new Web service extension:

2. Type the name of the new extension and click Add:

3. On the next dialog box, click Browse and navigate to the 2.0 version of aspnet_isapi.dll (it should be found in C:\Windows\Microsoft.NET\Framework\v2.0.50727), and then click OK.

4. Ensure that Set extension status to Allowed is enabled and click OK:

5. Make sure that the appropriate account has full access to the ASP.NET 2.0 Temporary ASP.NET Files folder. Navigate to the following folder:
C:\Windows\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files

6. Right-click that folder and select Sharing and Security:

7. Make sure that NETWORK SERVICE is listed. If it is not, click Add and type Network Service in the text box:

8. Once it is added, click on its entry in the list and allow Full Control on the Permissions list.

9. Click OK and restart IIS by bringing up a command prompt and typing IISRESET. The EdgeSight console should come up properly now.


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