Symptoms
When adding a printer on a workstation, the printer may not be autodetected by the ICA Client for Java version 9.x.
The printer is not visible in the Printer folder inside the ICA session or in the Parameters dialog box from the Connection Center.
Cause
The ICA Client for Java uses the Java Print Service application programming interface (API) from the Sun Java Virtual Machine (JVM). This API is called when the ICA Client for Java is executed.
If a printer is added after initially connecting with the ICA Client for Java and the Java cache contains a copy of the ICA .jar files, the Java client files present in the cache folder are used and not downloaded again. The autodetection process using the Java Print Service API is not able to detect the newly installed printers in this situation.
Resolution
Clear the Java application cache on the machine and/or the user profile.