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EdgeSight Report Error: Object reference not set to an instance of an object - Line 39 row["modifieddate'] = report.MofifiedDate

Document ID: CTX110998   /   Created On: Sep 7, 2006   /   Updated On: Aug 6, 2008
Average Rating: 4

Symptoms

The following error may occur when you click the My Reports section or any other report list icon such as Process > Stability > Errors or Device & Users > Performance > CPU:

“_______________________________________________________________
Server Error in '/' Application.
--------------------------------------------------------------------------------

Object reference not set to an instance of an object.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

Source Error:


Line 37: DataRow row - dt.Rows[i];
Line 38: CatalogItem report = GetReport((string)row["rs_reportid"]);
Line 39 row["modifieddate'] = report.MofifiedDate;
Line 40 }
Line 41 }


Source File: D:\Program Files\Reflectent\Server\EdgeSight 4.0\pages\common\controls\repmynodetemplate.ascx Line: 39

Stack Trace:


[NullReferenceException: Object reference not set to an instance of an object.]
ASP.repmynodetemplate_ascx.AddPropsToTable(DataTable dt) in D:\Program Files\Reflectent.....

_______________________________________________________________”

Cause

This is caused by duplicate or inconsistent Reporting Services globally unique identifier (GUID) information within the EdgeSight database. This can happen if you run the report upload more than once or after a server upgrade.

Resolution


Follow this procedure to resolve the above error in order to successfully use the EdgeSight reports.

1. Open the SQL Query Analyzer, connect to the EdgeSight database and issue the following SQL statements:

delete from rs_nodemap
delete from rs_subscription
delete from rs_report

2. Remove the Reporting Services reports. Use the following procedure to do this:

a. Using Internet Explorer, navigate to the following URL:

http://EdgeSightServerName/reports

If you are using legacy EdgeSight products, a Reflectent folder is visible on this page. In EdgeSight 4.5 and later, this folder is called Citrix.

b. Click the Show Details button on the right side of the page.

c. Select the check box to the left of the “Reflectent” or “Citrix” folder and click Delete.

d. Upload the Reporting Services reports again. Log on to the EdgeSight Server Console and navigate to the Server Settings > Reporting Services > Server page.

e. Fill in all the required information and make sure you upload the default reports as well as the default schedules.

The following screen shot shows the Report Server Settings page with the typical settings. Your settings may differ:

All the reports should now work properly.

More Information

This error only occurs when you try to select a report list icon. For example, the All Reports icon is a list icon that should bring you to a page with a long list of reports. All the operational pages as well as any summary reports function correctly.


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