Symptoms
After promoting domain users in the Citrix Management Console to Citrix administrators, they can run the Access Suite Console from the server directly without problems. However, if the Access Suite Console is installed on a client machine and a domain user tries to run Discovery the following error message is returned:
“Errors occurred when using ServerName in the discovery process”
Event ID: 10016 is seen in the Event Viewer.
Cause
This happens because a domain user does not have permission to start or activate COM/DCOM components remotely on a Terminal Server by default.
Resolution
All domain users assigned as Citrix administrators that do not require the same rights as domain administrators should be placed in an Active Directory group.
There are two possible ways to enable this group to run the Discovery process in the Access Suite Console:
1. Place this group in the local Administrators group on all Citrix servers (members of this group automatically have administrative rights on the local Citrix server).
2. Open Component Services on each Citrix server and browse to Component Services > Computer > My Computer.
3. Right-click and select Properties.
4. Select the COM Security tab and click Edit Limits for Launch and Activation Permissions.
5. Add the group with only remote activation rights.