Summary
After upgrading to Web Interface 4.x, the Java Client fails to launch.
Cause
The required client files are not in the new default location on the Web Interface server.
For Web Interface 4.0, 4.1, and 4.2:
The default location is the \Program Files\Citrix\Web Interface\4.x\ICAWEB\icajava folder on the Web Interface server.
For Web Interface 4.5:
The default location is the \Program Files\Citrix\Web Interface\4.5\Clients\icajava folder.
Previous versions of Web Interface stored the Java Client files in the default location of C:/inetpub/wwwroot/citrix/metaFrame/ICAWEB/en/icajava
Resolution
- Copy the contents of the ICAWEB/icajava folder on the Presentation CD-ROM to one of the following locations on the Web Interface server:
On Web Interface 4.0:
C:\Program Files\Citrix\Web Interface\4.0\ICAWEB\icajava
On Web Interface 4.1:
C:\Program Files\Citrix\Web Interface\4.1\ICAWEB\icajava
On Web Interface 4.2:
C:\Program Files\Citrix\Web Interface\4.2 \ICAWEB\icajava
On Web Interface 4.5:
Copy the contents of the Clients\icajava folder on the Presentation Server 4.5 CD-ROM to the following location on the Web Interface server:
C:\Program Files\Citrix\Web Interface\4.5 \Clients\icajava - Restart the Web services (issue the iisreset command at the command line). If you are on Internet Information Services (IIS) 6, proceed to Step 3.
- Recycle the application pool using the following procedure:
- Open IIS Manager.
- Select Application Pools.
- Right-click the CitrixWebInterfaceAppPool node and select Recycle.