[x]

Site Alert(s):

  • Server maintenance Saturday Nov 22, 2008, 12:00 PM - 3:00 PM. The Knowledge Center will be unavailable during this time.
Rate this Article:
You must be signed in to rate again
Article Feedback Print View
Alternate Languages:

SHIFT Key Fails Using RDP in a ICA Session

Document ID: CTX110281   /   Created On: Aug 8, 2006   /   Updated On: Jul 1, 2008
Average Rating: 3

Symptoms

The SHIFT key does not work (sporadic capitals and non-capital letters) when launching a published Microsoft RDP client (5.2.3790.1830) from the Windows 2003 operating system and using the Presentation Server Client for Java.

This issue does not impact Web Interface, Presentation Server, or ICA Client for Java Versions.

This issue does not occur when using Windows 2000 servers RDP Client (5.0.2195.6674).

Cause

When the Apply Windows key combinations setting is set to On the remote computer, the RDP client hooks into the keyboard at a lower level and this doesn’t appear to interact properly with the Presentation Server’s Unicode keyboard support.

Affected Clients

ICA Client for Java

ICA Client for Mac 10.x

Workaround

Change the RDP client settings as follows:

1. Click Options in the Remote Desktop Connection User Interface.

2. Select the Local Resources tab.

3. Under Keyboard > Apply Windows key combinations, select On the local computer.

After doing this, the SHIFT/ALT/CTRL keys work as expected in the RDP session.

More Information

Refer to CTX104566 – Shift key not Released, Causing Incorrect Multiple Selection with the ICA Java Client.

To update the RDP client, search RDP client.


Search
Knowledge Center
XenApp
XenApp Plugins (Clients)
XenServer
XenDesktop
NetScaler Application Delivery
Access Gateway
EdgeSight
Provisioning Server
WANScaler
Password Manager
Does it work with Citrix? Verify it - introducing the new Citrix Ready Community Verified