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Unsupported CCU Message in the License Debug Log

Document ID: CTX109667   /   Created On: Jun 14, 2006   /   Updated On: Feb 19, 2008
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Symptoms

When reviewing the lmgrd_debug.log random “UNSUPPORTED” messages are recorded, but users are not impacted. The specific “UNSUPPORTED” messaging is occurring for the concurrent user connection license “MPS_xxx_CCU.” Where xxx represents the product type:

• ENT for Enterprise

• ADV for Advance

• STD for Standard

Cause

There are two possible conditions where this may exist:

• A true “UNSUPPORTED” condition occurs in your environment. For example, if you purchase MetaFrame Presentation Server 3.0 Concurrent User Licenses and accidentally join a Citrix Presentation Server 4.0 to the farm. The user is denied connectivity to the Citrix Presentation Server 4.0 only.

• This may be a benign messaging event and the user is allowed connectivity.

Resolution

The purpose of the lmgrd_debug.log file is to debug potential Citrix licensing issues and it is not intended for administrative or monitoring purposes.

1. Validate the debug log output as benign because a true “UNSUPPORTED” condition could still occur. Enable Detailed logging by editing the citrix.opt file as per CTX104184 – How to Enable Connection Logging in the Citrix.opt File for Use in Troubleshooting Client Connectivity and begin making connections to the Presentation Server(s) in your farm. Open the debug log file with an editor (Notepad or Word Pad) and locate an “UNSUPPORTED” message.

    4:12:53 (CITRIX) UNSUPPORTED: "MPS_ENT_CCU" (14F1 1D12 0593 BCBE ) MPS@server.mycompany.com [d96aa8f5:MPSCLIENT] (License server does not support this feature (-18,327))

2. Identify the hardware ID of the device attempting to connect.

    4:12:53 (CITRIX) UNSUPPORTED: "MPS_ENT_CCU" (14F1 1D12 0593 BCBE ) MPS@server.mycompany.com [d96aa8f5:MPSCLIENT] (License server does not support this feature (-18,327))

3. Note the time stamp and continue to search later in the log until a license is checked out.

    4:12:53 (CITRIX) UNSUPPORTED: "MPS_ENT_CCU" (14F1 1D12 0593 BCBE ) MPS@ server.mycompany.com [d96aa8f5:MPSCLIENT] (License server does not support this feature (-18,327))
    4:12:53 (CITRIX) UNSUPPORTED: "MPS_ENT_CCU" (0A59 C190 8B1F 47F5 ) MPS@ server.mycompany.com [d96aa8f5:MPSCLIENT] (License server does not support this feature (-18,327))
    4:12:53 (CITRIX) UNSUPPORTED: "MPS_ENT_CCU" (051A DD93 1124 698A ) MPS@ server.mycompany.com [d96aa8f5:MPSCLIENT] (License server does not support this feature (-18,327))
    4:12:53 (CITRIX) UNSUPPORTED: "MPS_ENT_CCU" (0E71 514A 23C8 3AFE ) MPS@ server.mycompany.com [d96aa8f5:MPSCLIENT] (License server does not support this feature (-18,327))
    4:12:53 (CITRIX) OUT: "MPS_ENT_CCU" MPS@ server.mycompany.com [d96aa8f5:MPSCLIENT]

Although several “UNSUPPORTED” debug messages are generated, the client is never denied connectivity and is issued a license within a second of attempting to acquire a license in this example.

More Information

As of version 4.5 of the Citrix License Server, Citrix Systems Engineering has still identified the benign debug log messaging. This will be corrected in a future release of the Citrix License Server.

CTX104285 – License server messages in lmgrd_debug - "License server does not support this feature"


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