[タイトル]
公開アプリケーションのAdobe AcrobatやLotus Notesで印刷が正常に行われない
[現象]
公開アプリケーションのAdobe AcrobatやLotus NotesでCitrix Presentation Server 4.0サーバーのユニバーサルプリンタドライバ(UPD)機能を使用すると、印刷が正常に行われません。
[原因]
Citrix Presentation Server 4.0のユニバーサルプリンタドライバ(UPD)機能を使って印刷すると、クライアント側のビューアcpviewer.exeが印刷実行後に終了し、その時点で、スプールファイルに追加された一時フォントが解放されます。GREは、スプールファイルをディレクトリ%userprofile%¥local settings¥tempに作成するときに、各フォントがオペレーティングシステムの既知のフォントかどうかを確認し、それに従ってそのフォントを埋め込むかどうかを判断します。Adobe AcrobatやLotus Notesから印刷を実行すると、フォントが一時的にシステムに追加されます。追加されたフォントはスプールファイルがデスプールおよびレンダリングされるときにシステムから削除され、その結果、不正な文字が印刷されます。
Lotus Notesでは、文字が重なり合って印刷されるという現象が確認されました。
Adobe Acrobat 7.0では、「ٱ」などの不正な文字が印刷されるという現象が確認されました。
[解決方法]
この現象は、ICAクライアント9.150で解決されています。
CTX108436 - [Document Not Found]
[関連情報]
この資料は米国のCitrix Knowledge Baseで提供している情報をもとに作成したものです。
Document ID: CTX107427
Published Adobe Acrobat and Lotus Notes Exhibit Garbled Printing