[x]

Site Alert(s):

  • Server maintenance Saturday Nov 22, 2008, 12:00 PM - 3:00 PM. The Knowledge Center will be unavailable during this time.
Rate this Article:
You must be signed in to rate again
Article Feedback Print View
Alternate Languages: N/A

Message: Web Part timed out... in Web Interface for SharePoint

Document ID: CTX108834   /   Created On: Feb 17, 2006   /   Updated On: Feb 17, 2006
Average Rating: not yet rated

Symptoms

Every third logon to Web Interface for SharePoint returns the following message:

"Web Part timed out"

If you refresh Internet Explorer, the icons load up.

Cause

The issue being seen is a feature of SharePoint and it is common to many portals. When the Web Part goes to get the data to display your applications, the Web Part uses an asynchronous mechanism built into SharePoint. If this takes "too long" it could prevent the rest of the page from rendering.

Resolution

To stop this poor behavior, the asynchronous mechanism has a time-out, which is 7 seconds by default.

You can change this setting by modifying the following element in the web.config of your SharePoint instance (the value is in milliseconds).

<WebPartWorkItem Timeout="7000" />

This is usually found at:

C:\Inetpub\wwwroot\web.config

You should "tune" this value based on your infrastructure.

More Information

For additional information, refer to CTX108349 – Web Interface for Microsoft SharePoint Administrator's Guide.


This document applies to:

Search
Knowledge Center
XenApp
XenApp Plugins (Clients)
XenServer
XenDesktop
NetScaler Application Delivery
Access Gateway
EdgeSight
Provisioning Server
WANScaler
Password Manager
Does it work with Citrix? Verify it - introducing the new Citrix Ready Community Verified