Symptoms
Client printers fail to autocreate when users log on.
An event is written to the Event Log with ID 1116 from source “MetaFrame Events.” The event contains Printer auto-creation failure. Reason: AddPrinter() failed with status 0x78A.
C:\Documents and Settings\Administrator.FTLRLAB>net helpmsg 1930
The printer driver is not compatible with a policy enabled on your computer that blocks NT 4.0 drivers.
Cause
A Windows Server 2003 policy named “Disallow installation of printers using kernel-mode drivers” causes this issue.
Resolution
If the policy is set to “Enabled,” change it to “Not configured” and then run the following command from the command prompt:
Gpupdate /force
-Or-
If the policy is set to “Not configured,” change it to “Disabled” and then run the following command from the command prompt:
Gpupdate /force
Note: You should not experience the above issue if the policy is set to “Not configured.” However, the policy may be acting as though it is “Enabled.” Citrix Technical Support might ask you to set the policy to “Disabled.” If the policy is not behaving as expected, contact Microsoft.
More Information
If the above steps do not resolve the issue, this policy may be set at the domain level.
Citrix recommends customers do not use kernel-mode (version2) drivers unless absolutely necessary as they can potentially crash a server. Instead, user-mode (version3) drivers should be used exclusively to prevent crashes and maintain server stability.
CTX107137 – Troubleshooting Printing Problems In Presentation Server 4.0
CTX113261 – Troubleshooting Printer Issues in Presentation Server 4.5
CTX112792 – Can you use a kernel-mode printer driver (Version 2 driver) on a server running Citrix Presentation Server?
CTX112793 – What is the difference between a Kernel-mode driver and a User-mode driver?