Symptoms
Access Gateway devices hang after uploading a certificate with a password protected private key.
Cause
The Access Gateway requires access to the private key in order to create SSL sockets. Password protected private keys are encrypted and therefore inaccessible.
Resolution
The password must be removed from the private key and the device must be reinstalled from the CD along with a recent backup restored.
The OpenSSL toolkit can be used to remove the passphrase as follows:
openssl rsa -in key.pem -out newkey.pem
Status
The issue will be addressed in a future release of Access Gateway.
More Information
• CTX106627 - How to Install the OpenSSL Toolkit