Symptoms
In a specific install scenario, Web Interface for Microsoft SharePoint installation fails generating an error message.
Cause
The scenario in which this may occur is:
• The machine that Web Interface for Microsoft SharePoint is being installed on has Terminal Services installed.
— And —
• The machine is connecting to a remote SQL database. If this occurs, Web Interface for Microsoft SharePoint WebParts are not installed, and the configuration is not loaded into the SharePoint configuration database.
To correct this, you must run the command-line programs WebPartMgr.exe and SPConfigure.exe.
Resolution
To install missing WebParts using WebPartMgr.exe:
1. Launch a command window.
2. Navigate to C:\Program Files\Citrix\WISP\WebParts.
3. Type webpartmgr /a:e and press Enter.
This lists all the WebParts that have been successfully installed.
4. Type dir *.cab and press Enter.
This lists all the WebParts that are available.
5. Compare the list of installed WebParts (displayed in Step 3) to the list of those available (displayed in Step 4).
6. Add the missing WebParts using the following format:
webpartmgr /a:a <WebPart name>.cab
For example, to install the Launcher Web Part:
webpartmgr /a:a /f:WISP.Launcher.cab
7. Close the command window.
To load the configuration using SPConfigure:
1. Open a text editor (for example, Notepad).
2. Open the file C:\windows\system32\SPConfigure.log.
3. Examine the line starting with SPConfigure.EXE: Command:
4. Launch a command window.
5. Navigate to C:\Program Files\Citrix\WISP\Configure.
6. Run the commands indicated by the SPConfigure.EXE: Command entry.