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Application Fails to Display for Authenticated Users Who Log On to Web Interface for Microsoft SharePoint

Document ID: CTX108096   /   Created On: Dec 12, 2005   /   Updated On: Feb 22, 2006
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Symptoms

The Citrix Presentation Server Applications Web Part is added to my SharePoint site, but when users log on to the SharePoint site, no applications appear. The Web Part page does not display an error message indicating a problem.

Cause

The problem occurs because users are not accessing the SharePoint site using the NetBIOS name of the SharePoint Web server. By default the wisp_trust.config file only allows published applications to display if users access the site using the Web servers NetBIOS name.

Resolution

The following steps resolve this issue:

• Access the SharePoint site using the Web servers NetBIOS name

-or-

• Edit the wisp_trust.config file to add additional Connection Access (example: the IP or FQDN name of the SharePoint Web server)

Note: The wisp_trust.config file is located in the following directory:

%Program Files\common files\Microsoft Shared\web server extensions\60\CONFIG

Below is an example showing how to enable a published application display when connecting to a SharePoint server using the FQDN of the Web server.

To edit the wisp_trust.config file to support FQDN access:

  1. Open the sharepoint\CONFIG\wisp_trust.config file in a text editor.
  2. Scroll down to the area surrounded by ConnectAccess tags, where computer name is the computer name of the server running SharePoint.
    <ConnectAccess>
    <URI uri=https?://computer name/_layouts/WISP/.*” />
    </ConnectAccess>
  1. Add additional URI lines between the <ConnectAccess> and
  2. </ConnectAccess> tags in the following manner;

    <ConnectAccess>

<URI uri=https?://computer name/_layouts/WISP/.*” />

<URI uri=https?://FQDN/_layouts/WISP/.*” />

</ConnectAccess>

where FQDN is the FQDN of the server running SharePoint.

  1. Save the sharepoint\CONFIG\wisp_trust.config file, and close text editor.
  2. Restart IIS Services to apply the settings. From the Internet Information Services (IIS) Manager, select the computer name (local computer) item, and from the Action menu, choose All Tasks > Restart IIS....

Note: If after making this change applications still do not appear, make sure the computer name and DNS suffix properly match the name of the certificate. To confirm this right-click My Computer, go to Properties and select the computer name tab. Click Change, then More and double check the primary DNS suffix. This must match the suffix of the certificate.

More Information

Refer to CTX108349 – Web Interface for Microsoft SharePoint Administrator's Guide.


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