Symptoms
In a clustered license server environment, a user, who has rights to the License Management Console (LMC) for Access Suite 4.0, is not able to access the LMC using the URL http://<ClusterName>/lmc/index.jsp. After entering the URL, the user is prompted to enter his credentials. Even though correct credentials are provided, the user will be prompted to enter his credentials for a total of 3 times before receiving the error HTTP 401.1 – Unauthorized: Logon Failed.
Cause
When you setup Access Suite 4.0 licensing in a clustered environment, you run the license server install twice (once on each node in the cluster, assuming that it is a 2-node active-passive cluster) to the same shared directory. Hence, 2 different sets of secret keys are written to the files jk2.properties and workers.properties. The files are located in F:\Program Files\Citrix\Licensing\LMC\Tomcat\conf where F: is the cluster shared drive.
For example, you will see the following 2 secret keys in the workers.properties file:
worker.ajp13.secret = <secret key 1>
worker.ajp13.secret = <secret key 2>
You will also see following 2 secret keys in the jk2.properties file:
request.secret = <secret key 1>
request.secret = <secret key 2>
Resolution
This issue will be fixed in the next release of the LMC. In the meantime, you will need to make the following changes to resolve the issue:
1. Using the Cluster Administrator tool (C:\WINNT\cluster\cluadmin.exe), take the LMC and either IIS or Apache resources offline.
2. Delete one secret key from each file to resolve this issue. The set of keys that remain should be identical in both files.
For example, you should see only 1 secret key in the workers.properties file.
worker.ajp13.secret = <secret key 1>
You should also see only 1 secret key in the jk2.properties file, and it should be identical to that in the workers.properties file.
request.secret = <secret key 1>
3. From the cluster administrator tool, bring the LMC and either IIS or Apache resources online.