Symptoms
When printing from a Presentation Server 4.0 to an ICA 9.0 or later client, the print job will never print on the client machine. The job will spool and de-spool on the server but will never appear spooled by the client.
Cause
The print model, in Presentation Server 4.0 and the ICA 9.0 and later client, ushers all client print data into a client-side temporary file, in the user’s temporary directory. This temporary file is then opened by a helper application, PCL2BMP.EXE for PCL and PS data, CPVIEWER.EXE for EMF data. When the helper application tries to open this temp file, it may get an ACCESS DENIED. Also, if the user tries to open this file manually, they will get the same error. It appears as if the file is not being created properly (security tab is missing).
This only appears to be occurring with McAfee Enterprise 8.0i. McAfee has confirmed this to be a known issue with Enterprise 8.0i on Windows XP SP1 with Security Update 885835 and Windows XP SP2.
Resolution
Contact McAfee support for VirusScan Enterprise Patch 11. Install this on the Client machine.
OR
Downgrade the ICA client to 8.1 or earlier.
Note: Downgrading the client may result in a loss of functionality. Consult the respective ICA Client Administrator’s Guides to determine what features are not supported with older client versions.
More Information
Disabling McAfee on the client will not correct the problem. Removing McAfee can be used as a troubleshooting technique to confirm this issue and should not be used as solution.