[x]

Site Alert(s):

  • Server maintenance Saturday Nov 22, 2008, 12:00 PM - 3:00 PM. The Knowledge Center will be unavailable during this time.
Rate this Article:
You must be signed in to rate again
Article Feedback Print View
Alternate Languages:

SAP Business One Hangs, Crashes, and Closes

Document ID: CTX105984   /   Created On: Apr 11, 2005   /   Updated On: Dec 26, 2007
Average Rating: not yet rated

Symptoms

After submitting credentials to the logon screen, SAP Business One hangs and eventually crashes and closes.

Cause

SAP Business One crashes when the ClientName is over 15 characters long.

Possible Causes:

  • In Web Interface 3.0, with the Workspace Control feature enabled, the ClientName is unique for each client device and is frequently over 15 characters in length.
  • In Web Interface 3.0 with Workspace Control disabled, or when using a previous version of Web Interface, the ClientName is constructed based on the authenticating domain in conjunction with the user’s account name. For example, if a user “user” is authenticating to the “domain” domain, the ClientName value would be “domain-user.” If this combination results in a ClientName which exceeds 15 characters, they will also experience the problem.

Resolution

Temporary Workaround(s)

  1. Disable Workspace control on the Web Interface server. See page 53 of the Web Interface 3.0 Administrators Guide for detailed instructions.
  1. Modify the template.ica for Web Interface by adding a “#” sign in front of the, “ClientName=” ICA file tag. This will cause the ClientName value to be set to the hostname of the client machine.

Permanent Fix

Contact SAP support and request the March Service Market Place patch for SAP Business One.

More Information

For information on how the ClientName value is determined, refer to CTX859359 - How the Win32 ICA Client Determines the Value for ClientName.

The easiest way to verify the value of ClientName is to open the MetaFrame Presentation Server Console or the Citrix Management Console, find the user’s session under the Servers node and examine the Client Name value for that session.

If Dr. Watson is enabled on the server the following message will be recorded in the server’s Event Log. Specifics like date and time will vary, but the exception number, c0000005, should remain the same:

Source: DrWatson
Event ID:
4097
Description:
The application, , generated an application error The error occurred on 10/26/04 @ 17:23:02.242 The exception generated was c0000005 at address 77FCB3AD (RtlDestroyHeap)

See the following Microsoft documents for more information:

Microsoft article – How to disable/enable Dr. Watson for Windows

Microsoft article - Drwtsn32.exe does not create a User.dmp file or a complete log entry on a Windows Server 2003-based computer


Search
Knowledge Center
XenApp
XenApp Plugins (Clients)
XenServer
XenDesktop
NetScaler Application Delivery
Access Gateway
EdgeSight
Provisioning Server
WANScaler
Password Manager
Does it work with Citrix? Verify it - introducing the new Citrix Ready Community Verified