Citrix

Error: "Windows Cannot Access the Specified Device, Path, or File. You Might not have the Appropriate Permissions to Access them"

  • CTX105611
  • Created onMar 26, 2014
  • Updated onApr 01, 2014
Article Topic Connectivity

Symptoms or Error

Users logging on to a XenApp Server or XenDesktop are unable to execute files residing on client mapped drives and might receive one of the following error messages:

  • Error on Citrix Presentation Server 4.5 / XenApp 5.0:
    “Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access them.”

    User-added image

  • Error on Citrix XenApp 6.0:
    “Windows cannot access \\client\D$\setup.exe
    You do not have permission to access \\client\D$\setup.exe. Contact your network administrator to request access.”

    User-added image

  • Error on Citrix XenDesktop 5.0:
    “Windows cannot access the specified device, path, or file.  You may not have the appropriate permissions to access the item.”

    User-added image

Solution

As a security precaution, when a user logs on to a XenApp or XenDesktop session, by default, the server maps client drives without user execute permission. For users to be able to execute files residing on mapped client drives, editing the value of ExecuteFromMappedDrive in the registry on the XenApp server or XenDesktop machine to override the default behavior.

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

Complete the following steps to change the ExecuteFromMappedDrive registry setting in XenApp:

  1. After installing XenApp, run regedit.

  2. Find the following key:

    HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services/Cdm/ Parameters/ExecuteFromMappedDrive On Citrix XenApp 6.0, the registry location is different but still has the same values. The location on Citrix XenApp 6.0 is:

    HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services/picadm/ Parameters/ExecuteFromMappedDrive

  1. To grant users execute permission on mapped drives, set ExecuteFromMappedDrive to 1

    To deny users execute permission on mapped drives, which is the default, set ExecuteFromMappedDrive to 0.

  1. Restart the server for the change to take effect.

    User-added image

Complete the following steps to change the ExecuteFromMappedDrive registry setting in XenDesktop 5.0:

  1. After installing the Virtual Desktop Agent, run regedit.

  2. Navigate to the registry key HKEY_LOCAL_MACHINE\Software\Citrix\GroupPolicy\Defaults\.

  3. Create a new key, CDMSettings.

  4. Create a new REG_DWORD value called ExecuteFromMappedDrive and modify the value to 1 (0 is the default value).

  5. Restart the virtual desktop machine for the change to take effect.

    User-added image

Problem Cause

This is a security measure, by design, to control unwanted applications being launched on the user session.

Disclaimer

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Automatic translation

Important: This article was translated by an automatic translation system (also referred to as Machine Translation, or MT) and has not been translated or reviewed by people. Citrix offers a machine translated version of this article to allow for greater access to the support content. However, automatic translation is not always perfect and may contain errors of vocabulary, syntax or grammar. Citrix is not responsible for inconsistencies, errors or damage incurred as a result of the use of MT articles from our customers.Thank you.
Click here to see the English version of this article.
Languages
Was this helpful?
Thank you for your feedback

Share your comments or find out more about this topic

Citrix Forums