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Single Sign-on fails after installing PNAgent 8

Document ID: CTX104379   /   Created On: Jun 28, 2004   /   Updated On: Mar 22, 2005
Average Rating: 1

Symptoms

After installing PNAgent 8.0 from ica32pkg.msi, SSON (Single Sign On) may fail.

Cause

PNSSON does not get registered with the system.

Resolution

WARNING! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Use Registry Editor at your own risk. Make sure you back up the registry before you edit it.

1. Create a .reg file and include the following text.

NOTE: The drive letter in the ProviderPath may be different on some systems, adjust it accordingly:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\PnSson]

"Type"=dword:00000004

"IsEnabled"=dword:00000001

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\PnSson\NetworkProvider]

"ProviderPath"="C:\\Program Files\\Citrix\\ICA Client\\pnsson.dll"

"Class"=dword:00000002

"Name"="Citrix Single Sign On"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\PnSson\Enum]

"0"="Root\\LEGACY_PNSSON\\0000"

"Count"=dword:00000001

"NextInstance"=dword:00000001

3. Execute the .Reg file.

4. Reboot the system.

More Information

CTX368624 – Troubleshooting Citrix Pass-through Authentication (Single Sign-On)


This document applies to:

  • Windows (32/64 Bit)
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