The Password Manager Agent is Not Loading Upon the Launch of a Published Application
Symptoms
The MetaFrame Password Manager Agent fails to load when a user launches any published application in a farm.
Cause
The Ssolauncher.exe data value may be missing from the AppSetup value in the Winlogon Key. A reference to the Ssolauncher.exe file needs to be placed in the AppSetup value. Ssolauncher.exe ensures that essential MetaFrame Password Manager components (such as Ssoshell.exe, Ssobho.exe, and Ssomho.exe) are loaded. By so doing, the published application’s request for credentials will always follow the successful load of the MetaFrame Password Manager Agent.
Resolution
Ensure that the AppSetup value in the registry contains a reference to the Ssolauncher.exe file. The AppSetup value can be located by doing the following:
WARNING! This fix requires you to edit the registry. Using Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk.
1. Run the regedt32.exe registry editor
2. Navigate to the following registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
3. Double-click the AppSetup value located under the Winlogon key.
A reference to the Ssolauncher.exe file should have been added automatically when the Password Manager Agent was installed on the MetaFrame server. An example of the reference might be:
C:\Program Files\Citrix\MetaFrame Password Manager\wts\ssolauncher.exe /nossoshutdown
Note: The AppSetup value might contain additional data values (such as Cmstart.exe and UsrLogon.cmd) in addition to the reference to the automatically file.
Additional Information
See the Citrix Knowledgebase article CTX103190, “Undocumented Registry Features in MetaFrame Password Manager” for additional information about Ssolauncher.exe.