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Windows CE Clients are prompted to save ICA file with Web Interface 2.0

Document ID: CTX102921   /   Created On: Nov 11, 2003   /   Updated On: Jul 12, 2004
Average Rating: 2

Symptoms

When connecting to a Web Interface 2.0 server with a Windows CE Client, users are prompted with the following dialog box when they attempt to launch a published application:

You are downloading test.ica from <Web Interface server>:

“Would you like to open this file from its current location? or Save this file to disk?”

If you select open this file from its current location, the ICA session launches fine.

If you select save this file to disk, a save as dialog box appears momentarily, then the ICA session launches fine.

Cause

A check was put in place for the iPAQ PocketPC to verify that the ICA Client is installed on the device.

Resolution

As a workaround, you can edit the LaunchImpl.vbs file, which is located in inetpub\wwwroot\citrix\metaframexp\site\include\serverscripts and remove the following block:

If WinCE Then

Response.AddHeader "Content-Disposition," "attachment;filename=test.ica"

End If

Note: Implement this workaround only if you will not be using any iPAQ PocketPC devices to connect through the Web Interface. If any of your users intend to use PocketPCs, you have to extend the client detection logic to specifically detect PocketPCs.

Status

This issue is scheduled to be addressed in the next release of MetaFrame.

More Information

CTX654932 – Supporting NFuse Connections from the ICA Client for Windows CE and Web Aliases


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