Symptoms
When troubleshooting Step 4 of CTX681954 - Troubleshooting Citrix ICA Printer Autocreation, the following error message appears:
“Could not connect to the printer. You either entered a printer name that was incorrect or the specified printer is no longer connected to the server. Click help for more information.”

Causes
An entry was made in the Citrix Management Console, under Driver Compatibility, to disallow the driver in question.

Note: The issue could also be reproduced by selecting Allow only drivers in the list and, for example, adding the HP LaserJet 5 driver. This would disallow the HP LaserJet 4 as well as all other drivers.
- Or -
The Universal Printer Driver (UPD) was mapped to something else (logically such an action is contradictory to the usage of the UPD):
CTX089874 - Troubleshooting and Explaining the Citrix Universal Print Driver.

Resolution
Depending on the desired functionality, the result is either expected or the driver needs to be removed from the disallowed list.
- Or -
The mapping(s) should be removed.
Note: The Management Console should not allow for the same client driver to be mapped twice. Attempting to do so should return the following error message:
“The specified client driver already exists in the Mapping list.
Error code c0130023”
The root cause of this issue is unknown. However, deleting the mappings resolved the original issue of the UPD not mapping.
